Hlavní stránka > počítače > Problém při aktualizaci balíků v Debianu/Ubuntu – The following signatures couldn’t be verified because the public key is not available

Problém při aktualizaci balíků v Debianu/Ubuntu – The following signatures couldn’t be verified because the public key is not available

21.02.2010 (12,372 zobrazení) Komentuj Přejdi na komentáře

Dnes jsem chtěl z HW důvodu chtěl zkusit jiné jádro, než ve v Debian Lenny stable. Po přidání backportu do sources mi to ale hlásilo chybu v klíči a to: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY XXXXXXXXXX.

Po chvíli googlení jsem nalezl jednoduchý způsob a to:


gpg --keyserver subkeys.pgp.net --recv XXXXXXXXXX
gpg --export --armor XXXXXXXXXX | sudo apt-key add -
aptitude update</span>

a problém je vyřešen.

Aktualizace kódu:


Aktualizace
gpg –keyserver subkeys.pgp.net –recv-keys XXXXXXXXXX
gpg --export --armor XXXXXXXXXX | apt-key add -
aptitude update

Další aktualizace .D


gpg --keyserver subkeys.pgp.net --recv-key AED4B06F473041FA
  1. No comments yet.
  1. No trackbacks yet.

IMPORTANT! To be able to proceed, you need to solve the following simple math (so we know that you are a human) :-)

What is 2 + 3 ?
Please leave these two fields as-is:

mail
service
api